Retired Documentation:  You are using the documentation for version 1.7.3 which was retired in 2013. Go here for the latest version documentation or check here for your available upgrades to ExpressionEngine 3.

Requirements

We have created a Server Wizard that will verify whether your server is compatible with ExpressionEngine. To use the Wizard:

To create a site with ExpressionEngine, you must have at least minimal experience with HTML and understand how to create a website. Further, you must be familiar with the process of uploading files to your server via FTP.

To experience the full functionality of ExpressionEngine you must use a web browser with Javascript enabled. If Javascript is disabled, then some dynamic functionality in the Control Panel and other areas of the site may not function.

Server Requirements

Optional Requirements

Some features of ExpressionEngine are optional to use. However, in order to be able to use them you will need to meet their requirements.

Notes

Apache Server

If you are hosted on an Apache server it needs to be configured with AcceptPathInfo On for the URLs to work with the default settings. Most server are configured this way, but if yours is not then there are three options:

  1. Manually turn that feature on using a .htaccess file.
  2. Contact your Host or server admin to have them enable the option.
  3. Run your site using query strings. See the "Query String" section of the Explanation of URLs page for details.

URL Segment Support

If the Server Wizard lists URL Segment Support as Unsupported, you will need to run your ExpressionEngine site using query strings. The "Query String" section on the Explanation of URLs page contains the needed details.

Top of Page